Browse Source

Appveyor: Install OpenSSL to resolve a header/library mismatch

Install the mingw OpenSSL package in Appveyor. This makes sure that
the OpenSSL headers and libraries match in Tor's Appveyor builds.

(This bug was triggered by an Appveyor image update.)

Fixes bug 32449; bugfix on 0.3.5.6-rc.
teor 3 years ago
parent
commit
2abff832dd
2 changed files with 6 additions and 1 deletions
  1. 1 1
      .appveyor.yml
  2. 5 0
      changes/bug32449

+ 1 - 1
.appveyor.yml

@@ -62,7 +62,7 @@ install:
      #
      # Use pacman --debug to show package downloads and install locations
      #>
-    Execute-Command "C:\msys64\usr\bin\pacman" -Sy --verbose --needed --noconfirm ${env:mingw_prefix}-libevent ${env:mingw_prefix}-pkg-config ${env:mingw_prefix}-xz ${env:mingw_prefix}-zstd ;
+    Execute-Command "C:\msys64\usr\bin\pacman" -Sy --verbose --needed --noconfirm ${env:mingw_prefix}-libevent ${env:mingw_prefix}-openssl ${env:mingw_prefix}-pkg-config ${env:mingw_prefix}-xz ${env:mingw_prefix}-zstd ;
 
 build_script:
 - ps: >-

+ 5 - 0
changes/bug32449

@@ -0,0 +1,5 @@
+  o Minor bugfixes (CI, appveyor):
+    - Install the mingw OpenSSL package in Appveyor. This makes sure that
+      the OpenSSL headers and libraries match in Tor's Appveyor builds.
+      (This bug was triggered by an Appveyor image update.)
+      Fixes bug 32449; bugfix on 0.3.5.6-rc.