10_handle_no_units.dpatch 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. #! /bin/sh -e
  2. ## 10_handle_no_units.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.0.8+0.0.9rc1/src/or/config.c /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c
  22. --- tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 08:37:17.000000000 +0100
  23. +++ /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 11:56:02.494532062 +0100
  24. @@ -2237,6 +2237,7 @@
  25. };
  26. static struct unit_table_t memory_units[] = {
  27. + { "", 1 },
  28. { "b", 1<< 0 },
  29. { "byte", 1<< 0 },
  30. { "bytes", 1<< 0 },
  31. @@ -2257,6 +2258,7 @@
  32. };
  33. static struct unit_table_t time_units[] = {
  34. + { "", 1 },
  35. { "second", 1 },
  36. { "seconds", 1 },
  37. { "minute", 60 },