123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193 |
- export PACKAGE=tor
- include /usr/share/dpatch/dpatch.make
- export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
- export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
- ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
- confflags += --build $(DEB_HOST_GNU_TYPE)
- else
- confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
- endif
- CFLAGS ?= -Wall -g
- LOCALHOST_IP ?= $(shell getent hosts localhost | awk '{print $$1}')
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- else
- CFLAGS += -O2
- endif
- ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- RUN_TEST = no
- endif
- ifneq (,$(findstring notest,$(DEB_BUILD_OPTIONS)))
- RUN_TEST = no
- endif
- CONF_OPTIONS =
- ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
- CONF_OPTIONS += --with-dmalloc
- endif
- configure: patch-stamp
- config.status: configure
- @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
- dh_testdir
- CFLAGS="$(CFLAGS)" ./configure \
- $(confflags) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- --localstatedir=/var \
- --sysconfdir=/etc \
- $(CONF_OPTIONS)
- build: build-stamp
- build-stamp: config.status
- dh_testdir
- $(MAKE)
- @echo
- @echo
-
- @if [ "$(RUN_TEST)" != "no" ]; then \
- if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then \
- echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; \
- echo "src/or/test || true"; \
- src/or/test || true; \
- else \
- echo "src/or/test"; \
- src/or/test; \
- fi; \
- else \
- echo -e "\n\nSkipping unittests\n\n"; \
- fi
- @echo
-
-
-
-
-
-
-
-
-
- if [ "$(DEB_BUILD_GNU_TYPE)" = "s390-linux-gnu" ] || \
- [ "$(DEB_BUILD_GNU_TYPE)" = "sparc-linux-gnu" ] || \
- [ "$(DEB_BUILD_GNU_TYPE)" = "mipsel-linux" ]; then \
- cd doc/design-paper; \
- fig2dev -L pdf cell-struct.fig cell-struct.pdf || \
- ( echo "** Using shipped pdf file because fig2dev failed"; \
- perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-cell-struct.pdf > cell-struct.pdf ); \
- fig2dev -L pdf interaction.fig interaction.pdf || \
- ( echo "** Using shipped pdf file because fig2dev failed"; \
- perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-interaction.pdf > interaction.pdf ); \
- fi
-
- make -C doc/design-paper tor-design.ps tor-design.pdf
- touch build-stamp
- clean: unpatch
- dh_testdir
- dh_testroot
- rm -f build-stamp
- -$(MAKE) distclean
- dh_clean
- install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
-
- mv $(CURDIR)/debian/tor/etc/tor/torrc.sample $(CURDIR)/debian/tor/etc/tor/torrc
- mv $(CURDIR)/debian/tor/usr/bin/tor $(CURDIR)/debian/tor/usr/sbin/tor
- install -d $(CURDIR)/debian/tor/usr/share/man/man8
- mv $(CURDIR)/debian/tor/usr/share/man/man1/tor.1 $(CURDIR)/debian/tor/usr/share/man/man8/tor.8
- install -m 755 contrib/torify $(CURDIR)/debian/tor/usr/bin
- install -m 644 contrib/torify.1 $(CURDIR)/debian/tor/usr/share/man/man1
- install -m 644 contrib/tor-tsocks.conf $(CURDIR)/debian/tor/etc/tor
- install -m 644 debian/tor.lintian-override $(CURDIR)/debian/tor/usr/share/lintian/overrides/tor
- install -d -m 755 $(CURDIR)/debian/tor/usr/share/doc/tor/spec
- for i in doc/spec/*txt; do \
- install -m 644 $$i $(CURDIR)/debian/tor/usr/share/doc/tor/spec || exit 1; \
- done
- dh_link usr/share/man/man8/tor.8 usr/share/man/man5/torrc.5
- rm -f $(CURDIR)/debian/tor/usr/bin/tor-control.py
- install -d -m 755 $(CURDIR)/debian/tor-dbg/usr/share/doc
- ln -s tor $(CURDIR)/debian/tor-dbg/usr/share/doc/tor-dbg
- binary-indep: build install
- binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_installlogrotate
- dh_installinit
- dh_installman
- dh_link
-
- dh_strip --dbg-package=tor
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
- @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Result of testsuite has been ignored. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary install
|