06_add_compile_time_defaults.dpatch 2.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. #! /bin/sh -e
  2. ## 06_add_compile_time_defaults.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.1.1.5/src/or/config.c /tmp/dpep.Xv4cHn/tor-0.1.1.5/src/or/config.c
  22. --- tor-0.1.1.5/src/or/config.c 2005-01-12 16:32:45.000000000 +0100
  23. +++ /tmp/dpep.Xv4cHn/tor-0.1.1.5/src/or/config.c 2005-01-13 03:50:33.815693540 +0100
  24. @@ -108,7 +108,7 @@
  25. VAR("ContactInfo", STRING, ContactInfo, NULL),
  26. VAR("ControlPort", UINT, ControlPort, "0"),
  27. VAR("CookieAuthentication",BOOL, CookieAuthentication, "0"),
  28. - VAR("DataDirectory", STRING, DataDirectory, NULL),
  29. + VAR("DataDirectory", STRING, DataDirectory, "/var/lib/tor"),
  30. VAR("DebugLogFile", STRING, DebugLogFile, NULL),
  31. VAR("DirAllowPrivateAddresses",BOOL, DirAllowPrivateAddresses, NULL),
  32. VAR("DirBindAddress", LINELIST, DirBindAddress, NULL),
  33. @@ -159,7 +159,7 @@
  34. VAR("ORPort", UINT, ORPort, "0"),
  35. VAR("OutboundBindAddress", STRING, OutboundBindAddress, NULL),
  36. VAR("PathlenCoinWeight", DOUBLE, PathlenCoinWeight, "0.3"),
  37. - VAR("PidFile", STRING, PidFile, NULL),
  38. + VAR("PidFile", STRING, PidFile, "/var/run/tor/tor.pid"),
  39. VAR("ReachableAddresses", LINELIST, ReachableAddresses, NULL),
  40. VAR("RecommendedVersions", LINELIST, RecommendedVersions, NULL),
  41. VAR("RecommendedClientVersions", LINELIST, RecommendedClientVersions, NULL),
  42. @@ -167,7 +167,7 @@
  43. VAR("RendPostPeriod", INTERVAL, RendPostPeriod, "20 minutes"),
  44. VAR("RephistTrackTime", INTERVAL, RephistTrackTime, "24 hours"),
  45. OBSOLETE("RouterFile"),
  46. - VAR("RunAsDaemon", BOOL, RunAsDaemon, "0"),
  47. + VAR("RunAsDaemon", BOOL, RunAsDaemon, "1"),
  48. VAR("RunTesting", BOOL, RunTesting, "0"),
  49. VAR("SafeLogging", BOOL, SafeLogging, "1"),
  50. VAR("ShutdownWaitLength", INTERVAL, ShutdownWaitLength, "30 seconds"),