03_tor_manpage_in_section_8.dpatch 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. #! /bin/sh -e
  2. ## 03_tor_manpage_in_section_8.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: Move the Tor manpage from section 1 to section 8.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.1.1.5/contrib/torify.1 /tmp/dpep.fOA3Mm/tor-0.1.1.5/contrib/torify.1
  22. --- tor-0.1.1.5/contrib/torify.1
  23. +++ /tmp/dpep.fOA3Mm/tor-0.1.1.5/contrib/torify.1
  24. @@ -35,7 +35,7 @@
  25. to suid binaries.
  26. .SH SEE ALSO
  27. -.BR tor (1),
  28. +.BR tor (8),
  29. .BR tor-resolve (1),
  30. .BR torsocks (1),
  31. .BR tsocks (1),
  32. diff -urNad tor-0.1.1.5/doc/tor.1.in /tmp/dpep.fOA3Mm/tor-0.1.1.5/doc/tor.1.in
  33. --- tor-0.1.1.5/doc/tor.1.in
  34. +++ /tmp/dpep.fOA3Mm/tor-0.1.1.5/doc/tor.1.in
  35. @@ -1,4 +1,4 @@
  36. -.TH TOR 1 "August 2009" "TOR"
  37. +.TH TOR 8 "August 2009" "TOR"
  38. .SH NAME
  39. tor \- The second-generation onion router
  40. .SH SYNOPSIS