03_tor_manpage_in_section_8.dpatch 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. #! /bin/sh -e
  2. ## 03_tor_manpage_in_section_8.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.0.9pre5/contrib/torify.1 /tmp/dpep.fOA3Mm/tor-0.0.9pre5/contrib/torify.1
  22. --- tor-0.0.9pre5/contrib/torify.1 2004-11-10 03:27:09.608843380 +0100
  23. +++ /tmp/dpep.fOA3Mm/tor-0.0.9pre5/contrib/torify.1 2004-11-10 03:28:29.621248723 +0100
  24. @@ -18,6 +18,6 @@
  25. to suid binaries.
  26. .SH SEE ALSO
  27. -.BR tor (1),
  28. +.BR tor (8),
  29. .BR tsocks (1),
  30. .BR tsocks.conf (5).
  31. diff -urNad tor-0.0.9pre5/doc/tor.1.in /tmp/dpep.fOA3Mm/tor-0.0.9pre5/doc/tor.1.in
  32. --- tor-0.0.9pre5/doc/tor.1.in 2004-11-10 03:28:29.263327434 +0100
  33. +++ /tmp/dpep.fOA3Mm/tor-0.0.9pre5/doc/tor.1.in 2004-11-10 03:28:29.622248503 +0100
  34. @@ -1,4 +1,4 @@
  35. -.TH TOR 1 "November 2004" "TOR"
  36. +.TH TOR 8 "November 2004" "TOR"
  37. .SH NAME
  38. tor \- The second-generation onion router
  39. .SH SYNOPSIS