01_uncomment_datadirectory.dpatch 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. #! /bin/sh -e
  2. ## 01_uncomment_datadirectory.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad /home/weasel/projects/tor/cvs/src/config/torrc.sample.in cvs/src/config/torrc.sample.in
  22. --- /home/weasel/projects/tor/cvs/src/config/torrc.sample.in 2004-03-01 23:41:26.000000000 +0100
  23. +++ cvs/src/config/torrc.sample.in 2004-03-03 13:47:25.000000000 +0100
  24. @@ -11,7 +11,7 @@
  25. ##################### Below is just for servers #####################
  26. ## The directory for keeping all the keys/etc for this server
  27. -#DataDirectory @LOCALSTATEDIR@/lib/tor
  28. +DataDirectory @LOCALSTATEDIR@/lib/tor
  29. #Nickname moria # A unique handle for this server
  30. #Address moria.seul.org # The fqdn for this server