04_run_as_daemon.dpatch 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. #! /bin/sh -e
  2. ## 04_run_as_daemon.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad cvs/src/config/torrc.sample.in /tmp/dpep.ICyOZe/cvs/src/config/torrc.sample.in
  22. --- cvs/src/config/torrc.sample.in 2004-11-10 03:09:14.931082420 +0100
  23. +++ /tmp/dpep.ICyOZe/cvs/src/config/torrc.sample.in 2004-11-10 04:32:54.737527368 +0100
  24. @@ -32,7 +32,8 @@
  25. # Uncomment this to start the process in the background... or use
  26. # --runasdaemon 1 on the command line.
  27. -#RunAsDaemon 1
  28. +RunAsDaemon 1
  29. +PIDfile /var/run/tor/tor.pid
  30. # Tor only trusts directories signed with one of these keys, and
  31. # uses the given addresses to connect to the trusted directory