05_log_to_file.dpatch 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. #! /bin/sh -e
  2. ## 05_log_to_file.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad cvs/src/config/torrc.sample.in /tmp/dpep.5IEZdW/cvs/src/config/torrc.sample.in
  22. --- cvs/src/config/torrc.sample.in 2004-11-10 03:09:14.931082420 +0100
  23. +++ /tmp/dpep.5IEZdW/cvs/src/config/torrc.sample.in 2004-11-10 04:34:35.090758448 +0100
  24. @@ -19,6 +19,8 @@
  25. # Logs go to stdout unless redirected by something else, like one of
  26. # the below lines, or --logfile on the command line.
  27. +### Send all messages of level 'notice' or higher to @LOCALSTATEDIR@/log/tor/log
  28. +Log notice file @LOCALSTATEDIR@/log/tor/log
  29. ### Send all messages of level 'warn' or higher to @LOCALSTATEDIR@/log/tor/warnings
  30. #Log warn file @LOCALSTATEDIR@/log/tor/warnings
  31. ### Send all debug and info messages to @LOCALSTATEDIR@/log/tor/debug