02_add_debian_files_in_manpage.dpatch 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. #! /bin/sh -e
  2. ## 02_add_debian_files_in_manpage.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.0.9pre5/doc/tor.1.in /tmp/dpep.E9VjWB/tor-0.0.9pre5/doc/tor.1.in
  22. --- tor-0.0.9pre5/doc/tor.1.in 2004-11-10 02:20:59.000000000 +0100
  23. +++ /tmp/dpep.E9VjWB/tor-0.0.9pre5/doc/tor.1.in 2004-11-10 03:24:17.697639909 +0100
  24. @@ -333,6 +333,12 @@
  25. .TP
  26. .I @LOCALSTATEDIR@/lib/tor/
  27. The tor process stores keys and other data here.
  28. +.TP
  29. +.I /var/log/tor/
  30. +The tor server logs to this directory.
  31. +.TP
  32. +.I /var/run/tor/tor.pid
  33. +The PID of the tor (master) process is stored in this file.
  34. .SH SEE ALSO
  35. .BR privoxy (1),