06_add_compile_time_defaults.dpatch 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. #! /bin/sh -e
  2. ## 06_add_compile_time_defaults.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad cvs/src/or/config.c /tmp/dpep.XUCqlY/cvs/src/or/config.c
  22. --- cvs/src/or/config.c 2004-11-12 17:40:22.906576139 +0100
  23. +++ /tmp/dpep.XUCqlY/cvs/src/or/config.c 2004-11-12 17:58:01.603511522 +0100
  24. @@ -95,7 +95,7 @@
  25. VAR("ControlPort", UINT, ControlPort, "0"),
  26. VAR("CookieAuthentication",BOOL, CookieAuthentication, "0"),
  27. VAR("DebugLogFile", STRING, DebugLogFile, NULL),
  28. - VAR("DataDirectory", STRING, DataDirectory, NULL),
  29. + VAR("DataDirectory", STRING, DataDirectory, "/var/lib/tor"),
  30. VAR("DirPort", UINT, DirPort, "0"),
  31. VAR("DirBindAddress", LINELIST, DirBindAddress, NULL),
  32. VAR("DirFetchPostPeriod", UINT, DirFetchPostPeriod, "600"),
  33. @@ -135,11 +135,11 @@
  34. VAR("ORPort", UINT, ORPort, "0"),
  35. VAR("ORBindAddress", LINELIST, ORBindAddress, NULL),
  36. VAR("OutboundBindAddress", STRING, OutboundBindAddress, NULL),
  37. - VAR("PidFile", STRING, PidFile, NULL),
  38. + VAR("PidFile", STRING, PidFile, "/var/run/tor/tor.pid"),
  39. VAR("PathlenCoinWeight", DOUBLE, PathlenCoinWeight, "0.3"),
  40. VAR("RedirectExit", LINELIST, RedirectExit, NULL),
  41. OBSOLETE("RouterFile"),
  42. - VAR("RunAsDaemon", BOOL, RunAsDaemon, "0"),
  43. + VAR("RunAsDaemon", BOOL, RunAsDaemon, "1"),
  44. VAR("RunTesting", BOOL, RunTesting, "0"),
  45. VAR("RecommendedVersions", LINELIST, RecommendedVersions, NULL),
  46. VAR("RendNodes", STRING, RendNodes, NULL),