07_log_to_file_by_default.dpatch 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. #! /bin/sh -e
  2. ## 07_log_to_file_by_default.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.0.9rc7/src/or/config.c /tmp/dpep.BdF2iw/tor-0.0.9rc7/src/or/config.c
  22. --- tor-0.0.9rc7/src/or/config.c 2004-12-08 13:20:28.111199142 +0100
  23. +++ /tmp/dpep.BdF2iw/tor-0.0.9rc7/src/or/config.c 2004-12-08 13:22:08.294210420 +0100
  24. @@ -1179,7 +1179,7 @@
  25. /* Special case if no options are given. */
  26. if (!options->Logs) {
  27. - options->Logs = config_line_prepend(NULL, "Log", "notice stdout");
  28. + options->Logs = config_line_prepend(NULL, "Log", "notice file /var/log/tor/log");
  29. }
  30. if (config_init_logs(options, 1)<0) /* Validate the log(s) */