rules 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # GNU copyright 1997 to 1999 by Joey Hess.
  5. # Uncomment this to turn on verbose mode.
  6. #export DH_VERBOSE=1
  7. export PACKAGE=tor
  8. include /usr/share/dpatch/dpatch.make
  9. # These are used for cross-compiling and for saving the configure script
  10. # from having to guess our platform (since we know it already)
  11. #
  12. # See /usr/share/doc/autotools-dev/README.Debian.gz which suggests
  13. # this way of passing --build and --host. Also see the thread on
  14. # debian-devel './configure in debian/rules' from February/March 2006,
  15. # starting with <43FF212C.5020800@xs4all.nl> by Pjotr Kourzanov.
  16. export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
  17. export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
  18. ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
  19. confflags += --build $(DEB_HOST_GNU_TYPE)
  20. else
  21. confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
  22. endif
  23. CFLAGS ?= -Wall -g
  24. LOCALHOST_IP ?= $(shell getent hosts localhost | awk '{print $$1}')
  25. # Do not optimize the build with "noopt"
  26. ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
  27. CFLAGS += -O0
  28. else
  29. CFLAGS += -O2
  30. endif
  31. # Do not strip the binary with "nostrip"
  32. #ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
  33. # INSTALL_PROGRAM += -s
  34. #endif
  35. # Prevent the unit tests from being run with "nocheck"
  36. ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
  37. RUN_TEST = no
  38. endif
  39. ifneq (,$(findstring notest,$(DEB_BUILD_OPTIONS)))
  40. RUN_TEST = no
  41. endif
  42. CONF_OPTIONS =
  43. # build against libdmalloc4 - it better be installed
  44. ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
  45. CONF_OPTIONS += --with-dmalloc
  46. endif
  47. configure: patch-stamp
  48. config.status: configure
  49. @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
  50. dh_testdir
  51. CFLAGS="$(CFLAGS)" ./configure \
  52. $(confflags) \
  53. --prefix=/usr \
  54. --mandir=\$${prefix}/share/man \
  55. --infodir=\$${prefix}/share/info \
  56. --localstatedir=/var \
  57. --sysconfdir=/etc \
  58. $(CONF_OPTIONS)
  59. build: build-stamp
  60. build-stamp: config.status
  61. dh_testdir
  62. $(MAKE)
  63. @echo
  64. @echo
  65. # Running unit tests
  66. @if [ "$(RUN_TEST)" != "no" ]; then \
  67. if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then \
  68. echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; \
  69. echo "src/or/test || true"; \
  70. src/or/test || true; \
  71. else \
  72. echo "src/or/test"; \
  73. src/or/test; \
  74. fi; \
  75. else \
  76. echo -e "\n\nSkipping unittests\n\n"; \
  77. fi
  78. @echo
  79. # XXX
  80. # So, gs-gpl on s390 is broken (#321435) and fails to properly build
  81. # .pdf files from .fig files using fig2dev. Therefore we ship them
  82. # until this bug is fixed.
  83. #
  84. # of course we can always give it a try
  85. #
  86. # the hexdumps were built using something like
  87. # perl -e 'while (<>) { print unpack ("H*", $_); }' interaction.pdf | fold > hexdump-interaction.pdf
  88. if [ "$(DEB_BUILD_GNU_TYPE)" = "s390-linux-gnu" ] || \
  89. [ "$(DEB_BUILD_GNU_TYPE)" = "sparc-linux-gnu" ]; then \
  90. cd doc/design-paper; \
  91. fig2dev -L pdf cell-struct.fig cell-struct.pdf || \
  92. ( echo "** Using shipped pdf file because fig2dev failed"; \
  93. perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-cell-struct.pdf > cell-struct.pdf ); \
  94. fig2dev -L pdf interaction.fig interaction.pdf || \
  95. ( echo "** Using shipped pdf file because fig2dev failed"; \
  96. perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-interaction.pdf > interaction.pdf ); \
  97. fi
  98. # XXX ends
  99. make -C doc/design-paper tor-design.ps tor-design.pdf
  100. touch build-stamp
  101. clean: unpatch
  102. dh_testdir
  103. dh_testroot
  104. rm -f build-stamp
  105. -$(MAKE) distclean
  106. dh_clean
  107. install: build
  108. dh_testdir
  109. dh_testroot
  110. dh_clean -k
  111. dh_installdirs
  112. $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
  113. # move tor to where it belongs
  114. mv $(CURDIR)/debian/tor/etc/tor/torrc.sample $(CURDIR)/debian/tor/etc/tor/torrc
  115. mv $(CURDIR)/debian/tor/usr/bin/tor $(CURDIR)/debian/tor/usr/sbin/tor
  116. install -d $(CURDIR)/debian/tor/usr/share/man/man8
  117. mv $(CURDIR)/debian/tor/usr/share/man/man1/tor.1 $(CURDIR)/debian/tor/usr/share/man/man8/tor.8
  118. install -m 755 contrib/torify $(CURDIR)/debian/tor/usr/bin
  119. install -m 644 contrib/torify.1 $(CURDIR)/debian/tor/usr/share/man/man1
  120. install -m 644 contrib/tor-tsocks.conf $(CURDIR)/debian/tor/etc/tor
  121. install -m 644 debian/tor.lintian-override $(CURDIR)/debian/tor/usr/share/lintian/overrides/tor
  122. install -d -m 755 $(CURDIR)/debian/tor/usr/share/doc/tor/spec
  123. for i in doc/spec/*txt; do \
  124. install -m 644 $$i $(CURDIR)/debian/tor/usr/share/doc/tor/spec || exit 1; \
  125. done
  126. dh_link usr/share/man/man8/tor.8 usr/share/man/man5/torrc.5
  127. rm -f $(CURDIR)/debian/tor/usr/bin/tor-control.py
  128. install -d -m 755 $(CURDIR)/debian/tor-dbg/usr/share/doc
  129. ln -s tor $(CURDIR)/debian/tor-dbg/usr/share/doc/tor-dbg
  130. # Build architecture-independent files here.
  131. binary-indep: build install
  132. # We have nothing to do by default.
  133. # Build architecture-dependent files here.
  134. binary-arch: build install
  135. dh_testdir
  136. dh_testroot
  137. dh_installchangelogs ChangeLog
  138. dh_installdocs
  139. dh_installexamples
  140. # dh_install
  141. # dh_installdebconf
  142. dh_installlogrotate
  143. # dh_installemacsen
  144. # dh_installmime
  145. dh_installinit
  146. # dh_installcron
  147. dh_installman
  148. dh_link
  149. # Change this for debhelper compatibility level 5 or later!
  150. dh_strip --dbg-package=tor
  151. dh_compress
  152. dh_fixperms
  153. dh_installdeb
  154. dh_shlibdeps
  155. dh_gencontrol
  156. dh_md5sums
  157. dh_builddeb
  158. @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Result of testsuite has been ignored. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
  159. binary: binary-indep binary-arch
  160. .PHONY: build clean binary-indep binary-arch binary install