11_tor_as_root_more_helpful.dpatch 1.1 KB

123456789101112131415161718192021222324252627282930313233343536
  1. #! /bin/sh -e
  2. ## 08_no_run_as_root.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. --- tor~/src/or/main.c 2006-07-23 19:31:29.000000000 +0200
  22. +++ tor/src/or/main.c 2006-07-24 05:34:30.696138870 +0200
  23. @@ -1483,7 +1483,7 @@
  24. #ifndef MS_WINDOWS
  25. if (geteuid()==0)
  26. log_warn(LD_GENERAL,"You are running Tor as root. You don't need to, "
  27. - "and you probably shouldn't.");
  28. + "and you probably shouldn't. Maybe you are looking for the init script? '/etc/init.d/tor start'");
  29. #endif
  30. crypto_global_init(get_options()->HardwareAccel);