06_add_compile_time_defaults.dpatch 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. #! /bin/sh -e
  2. ## 06_add_compile_time_defaults.dpatch by <weasel@debian.org>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. if [ $# -lt 1 ]; then
  7. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  8. exit 1
  9. fi
  10. [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
  11. patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
  12. case "$1" in
  13. -patch) patch -p1 ${patch_opts} < $0;;
  14. -unpatch) patch -R -p1 ${patch_opts} < $0;;
  15. *)
  16. echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
  17. exit 1;;
  18. esac
  19. exit 0
  20. @DPATCH@
  21. diff -urNad tor-0.1.0.0-alpha-cvs/src/or/config.c /tmp/dpep.Xv4cHn/tor-0.1.0.0-alpha-cvs/src/or/config.c
  22. --- tor-0.1.0.0-alpha-cvs/src/or/config.c 2005-01-12 16:32:45.000000000 +0100
  23. +++ /tmp/dpep.Xv4cHn/tor-0.1.0.0-alpha-cvs/src/or/config.c 2005-01-13 03:50:33.815693540 +0100
  24. @@ -103,7 +103,7 @@
  25. VAR("ControlPort", UINT, ControlPort, "0"),
  26. VAR("CookieAuthentication",BOOL, CookieAuthentication, "0"),
  27. VAR("DebugLogFile", STRING, DebugLogFile, NULL),
  28. - VAR("DataDirectory", STRING, DataDirectory, NULL),
  29. + VAR("DataDirectory", STRING, DataDirectory, "/var/lib/tor"),
  30. VAR("DirAllowPrivateAddresses",BOOL, DirAllowPrivateAddresses, NULL),
  31. VAR("DirPort", UINT, DirPort, "0"),
  32. VAR("DirBindAddress", LINELIST, DirBindAddress, NULL),
  33. @@ -149,12 +149,12 @@
  34. VAR("ORPort", UINT, ORPort, "0"),
  35. VAR("ORBindAddress", LINELIST, ORBindAddress, NULL),
  36. VAR("OutboundBindAddress", STRING, OutboundBindAddress, NULL),
  37. - VAR("PidFile", STRING, PidFile, NULL),
  38. + VAR("PidFile", STRING, PidFile, "/var/run/tor/tor.pid"),
  39. VAR("LongLivedPorts", CSV, LongLivedPorts, "21,22,706,1863,5050,5190,5222,5223,6667,8300,8888"),
  40. VAR("PathlenCoinWeight", DOUBLE, PathlenCoinWeight, "0.3"),
  41. VAR("RedirectExit", LINELIST, RedirectExit, NULL),
  42. OBSOLETE("RouterFile"),
  43. - VAR("RunAsDaemon", BOOL, RunAsDaemon, "0"),
  44. + VAR("RunAsDaemon", BOOL, RunAsDaemon, "1"),
  45. VAR("RunTesting", BOOL, RunTesting, "0"),
  46. VAR("RecommendedVersions", LINELIST, RecommendedVersions, NULL),
  47. VAR("RendNodes", STRING, RendNodes, NULL),